Load Balancer Connectivity Issues Thursday 4th March 2021 21:08:00


Update (18 minutes later): Services should be restored for most users. We will continue to monitor over the next few hours.

Update (12 minutes later): We have identified the issue and are working to resolve it as soon as possible. Access should be restored shortly for most users.

We are currently experiencing increased error rates across our platform (website & app) and we are looking into the root cause. We will update this again when the issue has been identified and/or resolved.